站点图标 陌路寒暄

Beautiful Meadow

Beautiful Meadow

时间: 1ms        内存:64M

描述:


Tom's Meadow

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

1. Not all squares are covered with grass.
2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

输入:

The input contains multiple test cases!

Each test case starts with a line containing two integers N, M (1 <= N, M <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass. A line with N = 0 and M = 0 signals the end of the input, which should not be processed

输出:

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

示例输入:

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

示例输出:

Yes
No
No

提示:

参考答案(内存最优[752]):

#include"stdio.h"
#include"string.h"
int main()
{
    int i,j,k,l;
    int n,m,b,d;
    int a[11][11];
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        k=1;
        if(m==0&&n==0)
            break;
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        for(i=0; i<m; i++)
        {
            b=d=0;
            for(j=0; j<n; j++)
            {
                b=b+a[i][j];
                d=d+a[j][i];
                if(b>=n||d>=m)
                {
                    k=0;
                    break;
                }
            }
        }
        if(k==1)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

参考答案(时间最优[0]):

#include <iostream>
#include <cstdio>
#define MAX 12
using namespace std;
int map[MAX][MAX];
int a[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int n,m,sum,mark;
bool Bound(int x,int y)
{
    return (x>=0&&y>=0&&x<n&&y<m);
}

void Decide()
{
    int i,j,ti,tj,k;
    for(i=0; i<n; i++)
        for(j=0; j<m; j++)
        {
            if(map[i][j]==1)
            {
                sum++;
                continue;
            }
            for(k=0; k<4; k++)
            {
                ti=i+a[k][0];  //此处小心,绝不能写成i或者k,这里错过两次了
                tj=j+a[k][1];
                if(Bound(ti,tj))
                {
                    if(map[ti][tj]==0)
                    {
                        mark=1;
                        return ;
                    }
                }
            }
        }
}

int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        int i,j;
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                cin>>map[i][j];
        mark=0;
        sum=0;
        Decide();
        if(mark||sum==m*n)
            cout<<"No"<<endl;
        else
            cout<<"Yes"<<endl;
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版