站点图标 陌路寒暄

A+B for Input-Output Practice (IV)

A+B for Input-Output Practice (IV)

时间: 1ms        内存:64M

描述:

Your task is to Calculate the sum of some integers.

输入:

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

输出:

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

示例输入:

4 1 2 3 4
5 1 2 3 4 5
0 

示例输出:

10
15

提示:

参考答案(内存最优[748]):

#include<stdio.h>
int main()
{
	int a,c,d,j,i,sum;
	scanf("%d",&d);
	for(j=0;j<d;j++)
	{
	while(scanf("%d",&c)!=EOF)
	{  sum=0;
	    for(i=0;i<c;i++)
		{   
	 	    scanf("%d",&a);
		    sum=sum+a;
		}
	    printf("%d\n",sum);
	}
	}
	return 0;
}

参考答案(时间最优[0]):

#include<stdio.h>
int main()
{
	int a,c,d,j,i,sum;
	scanf("%d",&d);
	for(j=0;j<d;j++)
	{
	while(scanf("%d",&c)!=EOF)
	{  sum=0;
	    for(i=0;i<c;i++)
		{   
	 	    scanf("%d",&a);
		    sum=sum+a;
		}
	    printf("%d\n",sum);
	}
	}
	return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版